Equivalent Exchange

Allows the creation of high end materials out of base materials, as well as some very cool craft-able dark matter based items and tools

Download Mod Installer

MOD INFO

Creator

Pahimar (Current Developer)

x3n0ph0b3 (Original Creator)

Creators Description
To summarize: this mod allows you to transmute tons of materials into other materials. It adds a lot of what is classified by many as “endgame content”, to make you feel more godlike in your sandbox world. If this offends your Minecrafting sensibilities, this may not be the mod for you.
Mod Home Page

Not available

Minecraft Forum Page

http://www.minecraftforum.net/topic/1106178-/

DOWNLOAD AND INSTALL

Minecraft Mod Installer

Equivalent Exchange is available to install with Modgician’s Minecraft Mod Installer for the following versions

1.2.5
1.4.5
1.4.6
1.4.7
1.6.4
1.7.10
1.7.2

To use the Mod Installer, you will need a Modgician account

NOTE: Every time you use Modgician’s Minecraft Mod Installer, you are supporting mod developers and giving back to them financially.

Showing 18 comments
  • jonny1

    I LOVE THIS MOOOOOOODDDDD!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

  • esneT

    I’m having trouble installing it for 1.2.5 :( I put the EEClientV1.4.5.1 in the mods folder. When I went in game it loaded but when I used TMI the items didn’t show up. D:

  • esneT

    Never mind, I found out the problem. If you have the same problem, then check the file size. If it’s 1KB then it’s a shortcut, so go to your downloads folder and drag the actual jar file into the mods folder.

    • modman

      @esneT
      Ahhh yes, shortcuts don’t really do much do they :)
      Thanks for posting your fix.

  • logan.thorn

    I understand it will be quite some time until someone can read and reply to this, but when im sapposed to drag the 2 files over these files are NOT in the updated 1.4.6.2 version which was given from this site so if this could be updated or maybe im just blind and cannot see it. XD Thanks a bunch

    • modman

      @logan.thorn
      Hi, for 1.2.5 you don’t need to open the mod and copy the files out of it, just simply copy the download into the \.minecraft\mods\ folder
      There are two sets of instructions on the page above… one for MC v1.2.4 and prior and one for MC v1.2.5
      Hope that clears it up for you, let me know if not.
      Cheers

      • ROD1995

        sound doesnt work in 1.2.5

        • modman

          @ROD1995
          which sounds? for the whole game or just specific ones in EE2?

          • Portal543

            I have the same problem as him the sound doesn’t work both sounds but the mod itself works.
            so i checkout tekkit and technic the mod packs. The sound works for the game itself and the mod.
            Please help me modman

  • logan.thorn

    *Face Palm* Dang i guess i was blind after all! XD

  • brandito

    Someone please help when ever i put the EE2client folder it restarts my minecraft im not sure if its supposed to have these files in it though especially because of the 6th one heres what they say
    ..
    Buildcraft
    Codechicken
    Ee
    Ic2
    meta-inf
    Eeproxy.class
    Mcmod.info
    Mod_ee.class
    Please help asap

    • modman

      @brandito
      Are you closing Minecraft before installing EE2? By what you’ve described it sounds like your not.

  • Portal543

    The mod needed for EE2 (Equivalent Exchange 2) is only Forge not anymore Modloader, audio mod and Modloader mp you need them only for 1.2.4 and below :)

    Just saying because I wanted to download this mod so I searched on YouTube “How to install EE2 for 1.2.5”
    It said to dowload Modloader, Modloadermp audio mod and Forge. I tried that and it said minecraft had Crashed!
    I looked at the Forum and it said Now only need to install Forge! I don’t want the same thing to happen to other people :) it took me 3 days to figure it out :)

    • modman

      @Portal543
      Thanks! You’re right. Only needs Forge for 1.2.5 and later.
      Cheers

  • modman

    ADDED v0.1.142 FOR MINECRAFT 1.6.4
    ADDED v0.2.233 FOR MINECRAFT 1.7.2
    ADDED v0.2.362 FOR MINECRAFT 1.7.10

  • modman

    UPDATED TO v0.2.364 FOR MINECRAFT 1.7.10

  • modman

    UPDATED TO v0.2.369 IN MOD INSTALLER FOR MINECRAFT 1.7.10

  • fatbatman24

    UPDATED v0.3.0.547 IN MOD INSTALLER FOR MINECRAFT 1.7.10

Leave a Comment